Download + Install

Download

MyTourbook can be downloaded from sourceforge.net

 

Supported Platforms

This application is based on Eclipse, the supported platforms are documented here.

 

32 or 64 Bit

Whatever version of MyTourbook you use, you must use the same 32 or 64 bit version of Java, otherwise it will not work.

 

Installation

os linux Linux
os apple Mac OSX
os windows Windows

 

os linux

Linux

  1. The application requires Java 8 or higher which can be downloaded from here
  2. Download the Linux archive mytourbook-x.x.x-linux-32/64.zip from here and extract it to the location where it should be installed
  3. The file mytourbook is the application and the file attribute must be set to executable

 

To execute MyTourbook

  1. Open a terminal window
  2. Move to your MyTourbook installation directory e.g.:
    cd ~/mytourbook_12.1.0
  3. Run MyTourbook:
    ./mytourbook

 

Install OpenJDK 8

sudo add-apt-repository ppa:openjdk-r/ppa
sudo apt-get update
sudo apt-get install openjdk-8-jdk
sudo update-alternatives --config java
sudo update-alternatives --config javac

 

os windows

Windows

  1. The application requires Java 8 or higher which can be downloaded from here
  2. Download the Windows installation programm
    mytourbook-x.x.x-win-32/64-setup.exe from here and start the installation

 

os apple

Mac OS X

  1. The application requires Java 1.6 or higher which is already installed on OSX 10.4 or higher, newer Java versions can be downloaded from the Apple download site
  2. Download the Mac OSX archive mytourbook_x.x.x.macosx.carbon.<processor>.zip from here
    replace <processor> with the processor or you Mac
  3. Extract the archive and start the application

 

MyTourbook 11.3 was successfully tested on Mac OS X 10.7 Lion.

 

Mac OS X Support is discontinued since version 13.11

Any previous versions of MyTourbook did run properly with OS X 10.6 and Java 1.6.

MyTourbook 13.11 do not run properly with OS X 10.9 and Java 1.7 but before it worked at all, these problems needed to be fixed.

 

3D map did not run with Java 1.7

This problem occured:

org.eclipse.swt.SWTError: Not implemented (java.lang.ClassNotFoundException: apple.awt.CEmbeddedFrame)

which could be fixed with

SWT_AWT.embeddedFrameClass = "sun.lwawt.macosx.CViewEmbeddedFrame";

which caused this error:

javax.media.opengl.GLException: java.lang.NoClassDefFoundError: apple/awt/ComponentModel

upgrade from World Wind SDK 1.5 to 2.0 revision 1721 fixed this problem.

 

PackageMaker issue

OS X 10.6 PackageMaker did not run with OS X 10.9, after installing a new version it was running.

When running the MyTourbook installer which is created with the new PackageMaker, it do not install the app in the Application folder. The installer displays sucessfull installation but the Application folder is empty. Drag&drop of MyTourbook.app into the Application folder could be done and the app is also running but it has the following issues (these issues occure also when the app is not running within the Application folder).

Known issues when running MyTourbook 13.11 on OS X 10.9 (Mavericks)

  • 3D map can be displayed partly or not
  • 3D map hides quick views
  • Some user settings are not saved
  • The horizontal photo gallerie, which is displayed at the top of the fullscreen, is positioned in der vertical center
  • Tooltips/Dialogs are not opened with the mouse over event

 

There can still be other issues because only a quick and not a full test was done. It took many hours to get the first issues fixed and tested but the remaining issues are not yet fixed.

 

No problem with Linux

MyTourbook is being developed with Win7, the only adjustment which was needed to run version 13.11 on Linux (Ubuntu 12.04) was one UI layout adjustment, this was fixed in a few minutes. There was no need to spend many hours to get it running, compared with OS X. Why should I spend many more hours with the hope to get the problems fixed or not?

 

Download 13.11 for OS X 10.9

MyTourbook 13.11 for OS X 10.9 can be downloaded from here but it contains all problems which are described above. The downloaded app cannot be installed with an installer, just open the zip archive and run the included app.

 

 

 

 

 

This page is updated for version 16.4